Degradation of project creation & invitation

Incident Report for Globality

Resolved

On May 8, between 16:37 UTC and 23:55 UTC, Globality experienced platform impacts stemming from multiple high-volume operations. Based on this incident, we have optimized our platform to handle such operations without impacting overall platform performance.
Posted May 09, 2026 - 02:06 UTC

Monitoring

We have mitigated the issue and continue to monitor the platform’s health.
Posted May 08, 2026 - 23:55 UTC

Identified

We identified the root-cause for the issues, and working on a fix.
Posted May 08, 2026 - 17:16 UTC

Investigating

We are investigating reports from users who are experiencing issues with project creation & invitation.
Posted May 08, 2026 - 16:47 UTC
This incident affected: Project creation & invitation.